more bugs...



  • this project has had only bugs...
    https://prnt.sc/uf28wj



  • Wait for the update. Some of the errors in your screenshot do not make sense though, for example the one about Advertisements and RotateTurret.

    I have seen those for the first time. You need to provide more information such as which Unity version you are using. I cannot reproduce these issues with a screenshot alone.



  • Update 1.5.1 is now live on the Asset Store and fixes several Mirror issues with old versions.

    To reiterate, in a new project:

    • import the latest version of Mirror (17.3.0)
    • import Tanks Multiplayer 1.5.1
    • run the Window > Tanks Multiplayer > Network Setup
      -> Select Mirror in the dropdown
      -> Press Step 1, wait a bit for it to finish
      -> Press Step 2, it tells you to open all game scenes once and re-save them, do that

    This has been verified to work in Unity 2018.4 & 2019.4.



  • how the bug happens = install mirror, install tanks multiplayer, click on the step 1 so your asset can remove all scenes i did not ask to be removed, then find the scenes, save TDM and CTF again, press play, once TDM is loaded, watch the errors come in. Pretty hard to not reproduce these errors.
    2020.1.3f1



  • step 1 so your asset can remove all scenes i did not ask to be removed

    They are not removed. They are unloaded so the newly imported scripts can be compiled.

    Pretty hard to not reproduce these errors.
    2020.1.3f1

    I am not using a TECH stream of Unity versions for our assets. TECH versions are basically beta versions of Unity. I do not know how long you have been working with Unity before, but in the last 7 years I learned that each minor Unity version in a TECH stream can break things without prior notice. If you are starting a new project and are serious about releasing it, only LTS versions are used for development - the latest LTS version is 2019.4, where no errors show up with Tanks Multiplayer 1.5.1 as confirmed in my last post.



  • Well it wasn't listed on unity asset store that project doesn't work with later unity versions.
    And moving project to older versions is impossible, because most materials, most prefabs and scenes show an error that they've been serialized with newer version of unity.



  • We are publishing assets on the Unity Asset Store since 2013. I'm not discussing with you about new Unity versions, it is a fact that they are not stable at all. You can see this in multiple threads on the Unity forums.

    If you can't get our asset to work (I have to note that this is the only time I heard of), please send me your invoice number via email (info[at]rebound-games[dot]com) and I'll issue a refund.


Log in to reply