Current point doesn't change, Events don't work



  • Hey!

    I've been using your asset for a long time now and it's amazing. But I have a trouble now again. I started to use BezierPath for some places where I need rounded movement and I also using events every path. But when I created second Bezier path in the project events stopped work. I checked if they're changing in spline move and they do, path working correctly and everything. Then I tried to debug some things and I found out the problem by Debuging splineMove.currentPoint. For some reason it doesn't change on path. Exactly after creating more than one Bezier Path. It works perfect with other paths, but not with this. So, any ideas?



  • Hi there,

    I do not have an idea based on your description :)

    Could you reproduce the same issue in one of the sample scenes, with paths that exist there, so I could reproduce the issue on my end as well?

    Are you sure that there aren't any of your other scripts interfering with the movment scripts?



  • I tried to reproduce the issue and I understood the problem. For some reason when I add a Bezier Path Manager component to some object and create a path from children events on the path don't work. Just create a Bezier path that way and try it. And also I can't add waypoints when it created from children, object created but not a waypoint and there's a error in console: "ArgumentOutOfRangeException: Index must be within the bounds of the List.". So, maybe I'm stupid, but here's the resolution. Create a path with waypoint manager and not from children for bazier path.



  • Thanks for the additional explanation! Since bezier paths exist of not only waypoint game objects, but also 2 control points per waypoint, I guess the exception comes from not creating the control points? Honestly I can't remember anyone creating a bezier path from children, but I'll double check for the next update :)



  • No, I understand that. I mean after creating bezier path with children that have 2 additional children, if you create a waypoint through a bezier path manager component, it won't be treated as a waypoint and, well, events won't work. Thank you for help again, good luck :)


Log in to reply