Trying to place a waypoint but couldn't find valid target



  • Hey Baroni thanks for replying so quickly on the Unity forums and directing me over here.

    I have had a look at the thread you linked to me however it's of no use unfortunately. I did try resetting the view to default but it didn't help. However my problem is a little worse and I cannot create any waypoints at all in my own scenes. Only in your example scenes I can make waypoints and they load at the one point. So this factor is a little irrelevant but as an experiment it shows me that the system is working in some crippled way.

    So just to get you back up to track, I'm using the latest version of SWS on the latest version of Unity 2019.1.8f1 on the latest version of MacOs Mojave 10.14.5 - effectively I have the most up to do date and stable workflow for Unity -> Xcode ->iOS. I have been using various asset store products in this workflow flawlessly.

    And just to reiterate from the Unity Forum post: "In a new scene I add a plane with a collider. I add a Waypoint Manager. I enter a Path Name. I click 'Start Path'. But when I hover over the plane and press P no waypoints are added and I get this warning in my console:

    "Waypoint Manager: 3D Mode. Trying to place a waypoint but couldn't find valid target. Have you clicked on a collider?"

    But I DO have a collider! And it is the same dimensions as my plane. I have tried both the default mesh collider and box collider.

    There is nothing else with a collider in the scene. I have tried resetting the view to default. I have tried a couple hours of troubleshooting and experimenting including updating DOTween, comparing to example scenes and experimenting in the example scenes (which as mentioned above half works, but is irrelevant to my main problem in a new scene).

    Again really appreciate your help.

    Cheers,
    Brent



  • Hi Brent, thanks for registering!

    Could you let me know if the issue also occurs in one of the following scenarios?

    • New scene in new project
    • Different Unity version (e.g. 2018 if you have that installed)
    • Unity 2019.1.8f1 on a Windows PC (if you have access to one)

    I will try to get similar setup like you, however I would like to avoid updating my Macbook to Mojave so that leaves me with downloading Unity 2019.1.8f1...

    If you finished testing the points above, which are possible to you, could you please send me a zipped up project that reproduces the issue to our email address? Our email is linked on our main website.


Log in to reply