Unable to update to 5.4.4



  • Hi there

    I have tried to update my version of SWS but I receive the below errors. I currently have version 5.4.2 and Unity 2018.3.11f1

    Assets/SWS/Extensions/DOTween/Modules/DOTweenModuleSprite.cs(57,33): error CS0121: The call is ambiguous between the following methods or properties: `DG.Tweening.DOTweenModuleSprite.DOColor(this UnityEngine.SpriteRenderer, UnityEngine.Color, float)' and `DG.Tweening.ShortcutExtensions43.DOColor(this UnityEngine.SpriteRenderer, UnityEngine.Color, float)'
    
    

    and

    Assets/SWS/Extensions/DOTween/Modules/DOTweenModuleUI.cs(109,33): error CS0121: The call is ambiguous between the following methods or properties: `DG.Tweening.DOTweenModuleUI.DOColor(this UnityEngine.UI.Image, UnityEngine.Color, float)' and `DG.Tweening.ShortcutExtensions46.DOColor(this UnityEngine.UI.Image, UnityEngine.Color, float)'
    

    Any assistance would be appreciated. Thanks!



  • Hello,

    thanks for joining the forum!

    Since Simple Waypoint System comes with DOTween included, could it be that you either

    • have DOTween (Pro) in your project already, or
    • moved the previous DOTween folder somewhere else, so you now have two DOTween versions, or
    • did not remove the SWS folder before upgrading (in case there were conflicting scripts within DOTween)

    To summarize, deleting the DOTween (or full SWS) folder and importing the package again should fix this. Let me know if it does!



  • All good , deleted the entire SWS folder and reimported.

    Thanks so much for your help!


Log in to reply