Install conflict with DevDog's invPro relater fullserializer



  • When I install tutorial designer in my project Unity installs the fullserializer under my existing DevDog folder (which has a full serializer already). So nothing compiles.  In import screen of the asset store I can see that is where Unity wants to install it. I don't know if this a Unity bug or an error in your package build, but so far I can not use the two together. I will try other option than asset store installation.

    Cheers,
    Grant



  • Note all of this is in Unity 5.6
    I tried importing as a custom package
    importing to clean project (works OK in clean project) then exporting to new package
        renaming FullSerializer directory to FullSerializerX before export to new package
        deleting all .meta before export to new package
        deleting all .meta and renaming every subdirectory before exporting to new directory
    None of the above made any difference , Unity insists on installing on top of the existing FullSerializer files.



  • Test with unity 5.5 same problem.
    I did clean install of invpro then tried to import tutorial designer and unity installs the fullserializer under devg
    dog directory - overwriting existing files



  • Tried renaming file in FS subdirectories still Unity still overwrites exist FS files.

    --Solution here--
    Finally made a package of TutorialDesign with No FS and installed it. Then coped the FS directories from clean project with only tutorial design to existing project.  :) The demo scene ran and there are no compiler errors :)  so it looks good for now.

    Cheers,
    Grant



  • Did some more testing. Tutorial designer also break if FullInspector is installed.  The problem is that Unity packagemanager thinks your modified FullSerializer is an update of FullSerializer and overwrites files when yours are newer breaking everything.

    If you change all filenames and all directory names and THEN delete the meta file then make a package The unity package manager will not overwrite an existing FullSerializer installation.  I just added an X to end of all names. for testing. There may other solutions but this worked for me.

    Cheers,
    Grant



  • Hi Grant,

    thanks a lot for the detailed explanations! I will take a deep look at it, trying to reproduce this constellation. Until now i didn't notice that, putting FS in another Namespace was enough, like described on their GitHub Site. But this is an annoying issue, you uncovered there. So thanks again, I'll let you know when I came up with a solution for that.

    Cheers,
    Michael



  • Ok here is what worked for me:

    Situation:

    • Original FullSerializer in dev/FullSerializer

    Problem:

    • If I now import Tutorial Designer, Unity wants to overwrite dev/FullSerializer. No matter where the folder is, Unity finds it and wants to replace it.

    Solution:
    1.) Move the FullSerializer folder completely out of your Assets Folder of your Unity Project. It must not exist any more for Unity
    2.) Import Tutorial Designer. The custom FS package that comes by, will be in its original place under TutorialDesigner
    3.) Put your original FullSerializer folder back to dev/

    After those Steps I had both packages on their appropriate places, and the scene was running as is should. Hope that helps.

    Cheers,
    Michael



  • Thanks :)


Log in to reply